
Chapter Review Questions and Answers

Chapter 1

1. What is a protocol?

A protocol is a set of rules that allows digital communication across a 
variety of computer platforms. It includes Email, FTP (file transfer 
protocol), Listservs, Newsgroups, Bulletin Boards, Chat Rooms, and the 
World Wide Web.

2. For what does HTML stand? 

Hypertext Markup Language

3. What are Web-safe colors? 

Web-safe colors are RGB light source colors that can be viewed on the 
WWW without dithering or shifting the color. There are 216 colors that are 
cross-platform.

4. What punctuation marks are required when defining a color?

These marks must surround the color number: “#”

5. What tags are absolutely necessary to define a Web page?

<html>  </html>, <head> </head>, <title>  </title>, <body>  </body>

6. How can you provide additional information for a search engine?

Inside of the HEAD tag you can add a META tag to identify Keywords or 
Content-type (Description). The <meta> tag is followed by the codes 
“keywords” or “content-type”. 

Chapter 2

1. Why are images so important?

Images speak to our emotional selves and are absorbed without critical 
thinking. We believe in pictures as the truth.



2. What are some common image extensions?

JPEG, JPG, GIF, PNG, and SVG

3. How do you create a link?

by surrounding the information with <a> </a>

4. What is a TABLE?

A TABLE is a way to organize HTML information. TABLEs are made up of 
CELLs that are then arranged into rows and columns.

5. When would you want to use a TABLE?

Use a table anytime you want to organize information or images or both 
into a grid that will keep the information or images from jumping around on
the page. 

6. What does <rowspan> mean?

to have a column span more than one row

Chapter 3

1. What is the importance of organizing information for a Web site?

to visually present information and help the user move around in the Web 
site clearly, concisely, and effectively

2. Is Dreamweaver a vector-based or pixel-based Web authoring 
program?

pixel-based

3. How can you edit a site definition?

From the menu bar, select Site>Manage Site. Highlight the site that you 
want to edit and choose Edit.

4. How do you draw a layout cell?

Start in Layout View. Choose the Draw Layout Cell icon and move your 



pointer to the Document window. Click in the upper left corner and drag 
down and to the right to define a cell.

5. When do you use the Properties window?

whenever you want to display and modify information for any selected 
object or text

6. What is an Image Map? 

An Image Map is an image that has been divided into regions, or 
“hotspots”. When a hotspot is clicked, an action occurs.

Chapter 4

1. What are the three key ingredients for successful navigation?

clarity, consistency, and efficiency

2. What are three important considerations when designing a Web 
page?

any of the following: site and information design, interaction design, 
interface design, graphic design, HTML engineering, and programming

3. What is slicing?

Slicing divides the Photoshop or Illustrator page into sections that can 
then be redefined as cells in an HTML table. Slicing creates organization 
and faster download times.

4. How do you create a slice?

Use the slice tool to create divisions, then choose File>Save for Web.

5. How can you create a link that opens a new browser window?

by targeting the link as _blank

6. How do you access the Page Properties window? 

In the document window, from the menu bar, choose Modify>Page 
Properties.



Chapter 5

1. What is a frame-based document?

A frame-based document is an HTML organizational tool in which two or 
more individual HTML pages (frames) work together to look like a single 
page in a browser. Each frame is a single HTML document that acts 
independently. The HTML pages are held together and defined by a 
defined frameset HTML page.

2. How do you access frames?

To access frames, make certain that you are in the Standard Layout mode
of the Layout Tab of the Insert Bar. The icon to access frames is the 
second icon from the right in the Insert Bar. 

3. What is the difference between Save and Save Frame As in 
Dreamweaver?

Save will only save the document in which you are working. Save Frame 
As will save the frame as part of the frameset.

4. How can you access a frameset in the Dreamweaver document 
window?

From the document window menu bar, select View>Visual Aids>Frame 
Borders. Click on the heavy outlines around the frames in the document 
window. 

5. What is a rollover?

A rollover lets you seemingly stack two images on top of one another. This
appears as button highlighting. A simple image rollover makes three 
things happen. First, the images preloads when the Web page loads so 
that the rollovers are ready to go. Second, when the user mouses over the
specified image, a different image file is displayed. Finally, when the user 
mouses away from the image, the original image is restored.

6. How can you create a rollover image?

You will need to create separate images for the navigation elements and 
their rollovers in Photoshop or Illustrator. Save for the Web and from the 
Document window menu bar, select Insert>Images>Rollover Image or 
simply click on the Image button of the Common Tab of the Insert Bar. In 
either case, the Insert Rollover Image dialog box will appear. Select the 



source of the original image and the rollover image by typing the file 
names in the respective text boxes or clicking Browse to use the Original 
Source dialog box to select a local image. Leave the Preload Rollover 
Image box selected.

Chapter 6

1. What are the different states in four-part navigation?

A four-part navigation refers to the states of the mouse cursor. The Up 
State refers to the navigation image that sits on the page when it loads 
into the browser. The location of the mouse is not important as long as it is
not over the image. The Over State refers to the image that appears when
the user rolls the mouse over the Up State. The Hit State refers to the 
image that appears when the user clicks on the Up State. Finally, the Over
While Down State refers to the image which appears after the navigation 
image has been clicked. 

2. How is gesture considered when designing navigation?

The human gesture as it relates to technology is the user moving the 
mouse over the button. The resulting gesture is an interaction with 
technology creating an experience between human cause and 
technological consequences.

3. What is one consideration when using the concept of less is more?

Simplifying an image to its basic components or zooming in on the image 
to show only a small portion of it are all ways to visually describe an image
in a reduced fashion. Reducing the image to the simplest visual possible 
while remaining clear is the process of creating an icon. To use the 
concept of less is more allows the viewer to visually finish the image thus 
engaging the user’s conceptual process.

4. What is a style?

A style is a set of options saved to be used universally in a document or 
several documents.

5. How can you access a created style?

Styles are available through the Style drop-down menu in the Properties 
window, the Modify>Page Properties dialog box, and the Design palette. 
You can access a style in a different HTML page through Text>CSS 



Styles>Manage Styles>Attach. 

6. Where is Edit Style located?

You can edit a style through the Design pane. The lower right icon is the 
Edit Style icon. Click on this.

Chapter 7

1. Why use layers?

Layers offer the ability to add graphic elements that are not limited to the 
grid of cells, tables, or imported images. Once a layer is drawn, you can 
import images into it, add text, or you can use it simply as a graphic 
element by giving it a background color or any combination of the above.

2. How can you access layers?

You can access layers through the Insert pull-down menu. Scroll down to 
Layout Objects then over to Layers. This will place a layer on the page 
where the cursor was sitting. Alternately, and more precisely, from the 
Insert Bar of the Layout tab, choose the Layer icon. This icon will not be 
available if you are in Layout mode. You must be in the Standard or 
Expanded mode.

3. How do you make changes to layers?

Click on the edge of the layer shape to access the Properties window 
where you can type in the x and y coordinates, width and heights, color, 
and so forth. You can do anything in a layer that you can do on a page.

4. What is FTP?

File transfer protocol is a set of rules by which files can be transferred to 
and from the Internet.

5. When can you upload to the Internet?

After you have purchased a host, configured the Server information, and 
prepared your files, you can upload the Internet. Once connected, the 
connect icon will change to a disconnect icon and a remote file list will 
appear. To upload your files, select what you want to upload from the local
files and click the Put icon.



6. What must be the name of the first page in your Web site?

index.html or index.htm

Chapter 8

1. What is the document work area called?

a stage which is the actual area in which your images display, and a work 
area which is the space that extends beyond the stage on all sides but is 
outside the visible frame of the final, published document

2. How do you draw a circle with a Flash tool?

With the shift key pressed, use the Oval tool.

3. What is the timeline?

The timeline is a record of every frame, layer, and scene that makes up 
your document.

4. What is the playhead?

The small red rectangle with the line extending down from it in the timeline
is called the playhead. You can position the playhead where you want to 
be in the movie simply by dragging it to the appropriate frame.

5. What is the difference between a keyframe and a blank keyframe?

A keyframe holds new content while a blank keyframe is empty. Use the 
Insert>Timeline>Blank Keyframe command when you want to change the 
contents of the stage. Use Insert>Timeline>Keyframe when you want to 
duplicate the content of the preceding keyframe. A dark bullet in a frame in
the timeline indicates a keyframe with content. A hollow square indicates 
the last frame of that content and the gray tint on the frames in between 
indicates the continuing content.

6. What are a few ways to alter a shape or line?

With the Pen tool, alter, delete, or add points. With the Subselection tool, 
you can alter the handles of points. Use the smooth option of the Pencil 
tool. With the Free Transform tool, you can scale, rotate, and adjust.

Chapter 9



1. Where do you locate Create Motion Tween?

A motion tween is accessed through the pull-down menu of 
Insert>Timeline>Create Motion Tween.

2. What is a motion tween?

A motion tween in effect accomplishes frame-by-frame animation with a 
formula. Keyframes are required on either end of a motion tween. 

3. What happens to an object when you apply a motion tween to it?

Flash creates the in-between frames, breaking the motion into a series of 
small changes through a mathematical process.

4. What is a motion guide?

A motion guide is a path that guides the movement of a symbol in a 
motion tween. 

5. How do you make an object follow a given path?

You do this by creating a defined motion guide layer. Then, drag the 
symbol to reposition the registration mark directly over the beginning of 
this path.

6. How do you transfer an object from Illustrator to Flash? 

In Illustrator, you can export a graphic or series of graphics to .SWF 
format either as a single .SWF document, Illustrator layers to Flash 
frames, or Illustrator layers to Flash files.

Chapter 10

1. What is a mask?

A Flash Mask is like a window envelope. The mask is the window of the 
envelope and the linked, or masked layers, are the papers inside. You can
move the window around to see the various bits of information or you can 
move the papers beneath the window around or both. You can also 
animate the window.

2. How do you define a masked layer?



From the Modify pull-down menu, choose Timeline>Layer Properties to 
display the layer properties window. In the Type section, select Mask and 
rename the layer to identify it as a mask. Click OK. Flash turns the 
selected layer into a mask and changes the layer icon.

3. Can you animate a mask?

Masks can have motion tweens applied to them, be one or more editable 
shapes, and affect many linked layers.

4. What is a bitmap image?

In Flash, a bitmap image is a one-bit image using only black and white 
pixels.

5. What does it mean to “trace” an image?

Tracing an image converts a pixel-based image into a vector-based 
image.

6. How can you preserve transparency in an image for import into 
Flash?

Create a transparent layer in Photoshop and save as a PNG.

Chapter 11

1. What is ActionScript?

the programming language that Flash uses to stop, start, or otherwise 
create action or move a user around within a Flash Web site

2. What is syntax?

ActionScript has its own rules called syntax that organize and control such
things as word order, capitalization, spaces, and punctuation. Syntax uses
punctuation marks much like you would use mathematical symbols. Some 
common syntax marks are dots, semicolons, braces, and parenthesis.

3. How is ActionScript applied differently to a frame than it is to an 
object?

An object-based script tells the movie what to do next and is usually 
indicative of a goto action. To apply an action to an object, click on the 



object itself and assign the action. A frame-based script tells the timeline 
what to do next, such as stop the movie. To apply an action to a frame, 
insert a keyframe, click in the keyframe, and assign the action.

4. How is the button symbol timeline different from the main document 
timeline?

Button symbols have their own four-frame timeline and sit within one 
frame of the main document timeline.

5. What are the key ingredients of a button symbol timeline?

 up, over, down, and hit states

6. What are the basic codes used to assign an action to a button 
symbol? 

on and goto

Chapter 12

1. What is a movie clip?

A movie clip is a symbol with its own timeline. 

2. How many layers can a movie clip contain?

A movie clip sits in one frame of the document timeline and has its own 
timeline with as many layers as desired. 

3. Where can a designer use a movie clip?

Movie clips can be nested inside of Button Symbols, inside of other Movie 
Clips, or simply placed in the document’s timeline. Some designers will 
use movie clips as an organizational tool. Each “page” of the Web site is in
fact a movie clip.

4. Does a movie clip have to contain animation?

no

5. Where are ActionScripts that control movie clips?



onClipEvent, stop, startDrag, stopDrag, load and unload to name a few

6. What does the script _root reference?

the first level or main document of a Web site

Chapter 13

1. How can you sync a sound to an action?

Set the sound’s sync to Start in the keyframe in which an action is 
assigned.

2. Where do you go to edit a sound?

You can manipulate sounds through the Edit Envelope available from the 
Properties window. Here you can change the fades, loops, and edits.

3. What tool do you use to view the effects of sound on a movie’s 
profile?

the bandwidth profiler available through the Test Movie mode

4. What are four ways to compress sound?

For short sounds, choose ADPCM. 
For longer streaming sounds, choose MP3.
Set kHz at 22 or 11, choose lower bits, and mono or stereo. 
To omit sound compression, choose Raw. 
To set compression for sounds consisting of spoken words, choose 
Speech.

5. What is the Video Import Wizard?

In Flash, when you import a video, a new window will open called Video 
Import Wizard. With this window, you can embed or link a video.

6. How can you edit video in Flash?

In the Video Import Wizard window, choose Edit First. A new window will 
open with an editing mode. Move the triangles around to edit, preview, 
and create clips. The clips that you create will show up in the Clip pane. 



Chapter 14

1. What is an instance?

It is each individual time that a symbol is used. Different actions and 
properties can be assigned to each instance.

2. What does it mean to distribute to layers?

an organizational tool that when an object has been broken apart, each 
part of the object is distributed to its own layer and named

3. How can you add frames to more than one layer at a time?

Click in a frame on the first layer. Hold down the shift key and click in the 
same frame of the last layer. This should highlight the frame in all of the 
layers. Choose Insert>Timeline>Frame. All layers will add these frames.

4. How can you copy frames and layers from one scene to another?

In the first scene, highlight the frames and layers that you want to copy. 
Choose Edit>Timeline>Copy Frames. Place your cursor in a single frame 
in the next scene. Choose Edit>Timeline>Paste Frames. Flash will paste 
the frames, layers, layer names, and ActionScript in exactly the same 
place each time.

5. What panel do you use to change the name of a scene?

the Scene panel

6. How can scenes be effective in organizing a Web site?

by treating each scene as a Web page

7. When would you want to use scenes to organize a Web site?

when your Web site is text heavy and image light

Chapter 15

1. What is loadMovieNum?

a root ActionScript.



2. How does loadMovieNum work?

LoadMovieNum is a root ActionScript that loads a SWF file on top of 
another SWF file. It doesn’t actually replace the original SWF file. Instead, 
it treats the background of the top SWF as transparent.

3. Do you need HTML documents beyond index.html?

no

4. Can you place navigation inside of a movie clip?

yes

5. When would you want to use the loadMovieNum method to organize 
a Web site? 

when your Web site is image heavy

Chapter 16

1. What does the Bandwidth Profiler show you?

The Bandwidth Profiler will show the amount of data that is being 
transmitted against the movie’s timeline. The bars represent the number of
bytes of data per frame. The bottom line (highlighted in red) represents the
amount of data that will safely download fast enough to keep up with the 
movie’s frame rate.

2. What can you accomplish on the Formats tab of the Publish Settings 
dialog box?

The Formats tab allows you to determine the file names and extensions 
that will be read by the browser.

3. What can you accomplish on the Flash tab of the Publish Settings 
dialog box?

The Flash tab settings are going to determine who can view your site and 
what the quality of that viewing experience will be.

4. What can you accomplish on the HTML tab of the Publish Settings 
dialog box?

The HTML tab controls the published HTML file. This is the actual file that 



the browser will read.

5. How can you identify information for a search engine?

by adding the <meta> tag along with keywords and bontent description 
inside of the <head> </head> tags

6. How can you upload a SWF file from your computer to the Internet?

through an FTP program once you have contracted with a host, have a 
user ID, and a password


	Chapter Review Questions and Answers

